[Samba] broken samba-4.1.7 waf configure

squidmobile at fastmail.fm squidmobile at fastmail.fm
Sat May 31 11:46:21 MDT 2014

31 may 2014


in the (relatively distant) past, i several times downloaded,
built, and ran the then-current version of samba with little to no
problem.  i recently experienced similar successful results with

i downloaded and tried to configure samba-4.1.7, which you (samba)
advertise as the current "stable" version.  i expected no problems.
unfortunately, i encountered major problems with waf.

./configure (which points to ./buildtools/bin/waf configure)
reports this when it gets to mit krb5:

Looking for kerberos features
Checking for program krb5-config.heimdal          : not found
Checking for program krb5-config                  :
Checking for /local/bin/krb5-config               : yes
Checking for gssapi                               : yes
Kerberos 5 release 1.12.1 is detected, MIT krb5 build can proceed
Checking for com_err                              : yes
Checking for library com_err                      : yes
Checking for _et_list                             : ok
Checking for header com_err.h                     : yes
Checking for header krb5.h                        : yes
Checking for header krb5/locate_plugin.h          : yes
Checking for header gssapi.h                      : yes
Checking for header gssapi/gssapi_generic.h       : yes
Checking for header gssapi/gssapi.h               : yes
Checking for header gssapi/gssapi_ext.h           : yes
Checking for header gssapi/gssapi_krb5.h          : yes
Checking for library k5crypto                     : not found
Checking for krb5_encrypt_data                    : not found

/local/bin/krb5-config --libs --cflags reports:
  -L/local/package/krb5-1.12.1/lib -Wl,--enable-new-dtags -Wl,-rpath
  -Wl,/local/package/krb5-1.12.1/lib -lkrb5 -lk5crypto -lcom_err

running ./configure with the -v option gives this interesting dialog:

Checking for header gssapi/gssapi_krb5.h          :
21:53:04 runner /usr/bin/gcc -MD -I/usr/local/include
-I/local/package/krb5-1.12.1/include -D_SAMBA_BUILD_=4 -DHAVE_CONFIG_H=1

Checking for library k5crypto                     :
21:53:04 runner /usr/bin/gcc -MD -I/usr/local/include -D_SAMBA_BUILD_=4
-c -o default/test_1.o
21:53:04 runner /usr/bin/gcc default/test_1.o -o
-fstack-protector -Wl,-no-undefined -L/usr/local/lib -Wl,-Bdynamic
not found

i find it peculiar that the gssapi/gssapi_krb5.h test used the
proper -I flag, but the k5crypto test included NEITHER the
proper -I flag nor the -L flag.  nor did it find -lk5crypto
in the location indicated by /etc/ld.so.conf and ldconfig -p ...

your waf program set flags that broke the subsequent waf build

i think i ran into similar problems with it not finding openldap.

btw- i find it interesting/amusing that your waf program loved
the /usr/local/include and /usr/local/lib directories even though
they contain absolutely nothing...

begin soapbox diatribe:
  i have run into waf in more than one package.  EVERY time, waf
  screws up to the point where its package will NOT compile at all.
  i wish you would go back to the traditional ./configure program
  that works well countless times with countless packages.
end soapbox mode.

please correct your dependency upon fixed locations
(/usr/local/...) and restore the flexibility provided by

the frustrated
frank smith

http://www.fastmail.fm - Same, same, but different...

More information about the samba mailing list