[Samba] Folders/files losing security access

bogdan_bartos admin at blackpenguin.org
Fri May 30 12:43:13 MDT 2014

Hi all,

I have been experiecing this issue since the first release of samba 4.0. I
am running samba 4.1.7 in a production environment for about 25 people -
higher the user/work volume, the more frequent the security access loss.

Every once in a while a user calls me to report that he cannot write/delete
or modify certain files or folders. The only fix that I can apply (this also
worked in samba 4.0) is to move out the folder with issues to a temporary
share, then move it back to the proper location. Like this I fix the file
access consistency issues that occur.

However this should never occur! I also tried to remove the user right from
the share and re-assign them, but it never works. Only the move out/in seems
to fix it. Is anybody else experiencing the same issue? Is there a bug
reported for it? I cannot provide logs since I do not know when it's
happening since it's rare.

I encountered this issue on different installs on different systems numerous
times. This is the actual reason I could not deploy samba 4.0 in production
when it first went out live and the issue is still haunting aroung.

View this message in context: http://samba.2283325.n4.nabble.com/Folders-files-losing-security-access-tp4666720.html
Sent from the Samba - General mailing list archive at Nabble.com.

More information about the samba mailing list