[Samba] Ubuntu client ddns failure [SOLVED]

L.P.H. van Belle belle at bazuin.nl
Thu May 22 06:45:59 MDT 2014

no, FQDN in /etc/hostname. 

as you see here. 

cat /etc/hostname

hostname -s

hostname -d

hostname -f

getent hosts mail1.bazuin.nl
192.168.xxx.xxx mail1.bazuin.nl
195.xxx.xxx.xxx mail1.bazuin.nl

getent hosts 192.168.xxx.xxx
192.168.xxx.xxx mail1.bazuin.nl

all correct. 

Debian Reference specify that it is the unqualified hostname 
that should appear in this file /etc/hostname

Steve did you put "domain hh3.site" in resolv.conf ? 
if not, do it. 
put the "single hostname " in /etc/hostname 
hostname -F /etc/hostname 

and recheck with above commands. 



>-----Oorspronkelijk bericht-----
>Van: steve at steve-ss.com [mailto:samba-bounces at lists.samba.org] 
>Namens steve
>Verzonden: donderdag 22 mei 2014 14:45
>Aan: samba at lists.samba.org
>Onderwerp: Re: [Samba] Ubuntu client ddns failure [SOLVED]
>On 22/05/14 14:43, steve wrote:
>> On 22/05/14 14:33, L.P.H. van Belle wrote:
>>> At the install of ubunt i should have ask the domainname.
>>> Did you enter it? ( i gues not ) common problem, lots of people dont
>>> fill anything here.
>> It's Lubuntu. Can't remember it asking. Which file does it 
>live in? That
>> would explain the short hostname bit.
>> Cheers,
>> Steve
>>> Louis
>>>> -----Oorspronkelijk bericht-----
>>>> Van: steve at steve-ss.com [mailto:samba-bounces at lists.samba.org]
>>>> Namens steve
>>>> Verzonden: donderdag 22 mei 2014 14:29
>>>> Aan: samba at lists.samba.org
>>>> Onderwerp: Re: [Samba] Ubuntu client ddns failure [SOLVED]
>>>> On 22/05/14 14:22, Rowland Penny wrote:
>>>>> On 22/05/14 13:19, steve wrote:
>>>>>> Nailed it:
>>>>>> /etc/hostname has to have the fqdn:
>>>>>> lubuntu-laptop.hh3.site
>>>>>> So now, hostname returns incorrectly but hostname -s and 
>hostname -f
>>>>>> are OK. That gotta be a bug no?
>>>>>> Relief.
>>>>>> Cheers,
>>>>>> Steve
>>>>> You beat me to it, I thought that might be a workround, 
>but what does
>>>>> opensuse have in /etc/hostname ?
>>>>> Rowland
>>>> Great minds Rowland. . .
>>>> openSUSE has the short hostname, as expected.
>>>> So, on Ubuntu, hostname is wrong but hostname -f, hostname -d and
>>>> hostname -d are still OK.
>>>> Just worried that the wrong entry in /etc/hostname is gonna break
>>>> something we've not met yet.
>>>> Cheers,
>>>> Steve
>Seems as if Debian needs fqdn in /etc/hostname
>To unsubscribe from this list go to the following URL and read the
>instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list