[Samba] Auth fail getpwuid(3000007) failed

Andrea Venturoli ml at netfence.it
Sun May 18 03:31:09 MDT 2014

On 05/17/14 18:02, Leander S. wrote:

> Hi Andrea,
> thanks for your reply.

Thanks to you!

> Fortunately I was able to solve it. I recompiled samb=
> a and everything worked out as expected. Funny but I can't tell why, since t=
> he config stayed exactly the very same as before ;)

I did a "portupgrade -Rf samba", thus recompiling everything 
(dependencies included), but this did not help.

> Switching off winbind also did not help to solve my problem. Issues where st=
> ill the very same when I tried this. Since I run a plane so called standalon=
> e fileserver, I currently anyway don't have winbind switched on.

In my case, since samba sometimes fails, sometimes not, it's hard to 
tell; I'm sure I never saw it failing with winbind turned off.
Alas, I need winbind for PAM.

> One cause of your trouble could alsobe the way of how you initialize thesamb=
> a server.

I'm using the rc script provided by the port.

> Are you using samba-tools?


> Is your FreeBSD freshly installed, or isitan older system where you changed s=
> omething recently? ... maybe some updates?

Sure: this box was installed at the beginning of this year and has 
worked flawlessly for some months. The I did some upgrades and Samba 
started misbehaving.
I still have my dumps from before the upgrade, though I always prefer 
understanding what's going on to a blind restore.

  bye & Thanks

More information about the samba mailing list