[Samba] MS Remote Desktop issue related to Samba 4 ?

Andreas Oster aoster at novanetwork.de
Wed May 14 02:47:53 MDT 2014


Am 13.05.2014 18:27, schrieb Marc Muehlfeld:
> Hello Andreas,
> 
> Am 13.05.2014 15:55, schrieb Andreas Oster:
>> I am currently struggling with an odd MS Remote Desktop issue which
>> might be related to our Samba4 AD (version: 4.2.0pre1-GIT-d7c22d5
>> domain/forest-level 2008_R2) setup.
>>
>> We are unable to connect to Win7 machines (all available latest patches
>> installed) via RDP after they have been joined to the domain. We have
>> made sure, that RDP is enabled and the firewall exceptions are in place.
>> We actually tried with firewall turned off, also. When trying to connect
>> with an AD account we get to the welcome screen but not further. The
>> physical screen of the machine does not get locked. When doing the same,
>> using a local admin account we can successfully log in via RDP.
>>
>> Does anybody have an idea what could be the cause of this issue ?
>>
>> I tested the same at home in my small samba4 domain, without any
>> modified GPOs, and face the same issue.
> 
> My first guess was that, a GPO or a local policy could cause that. But
> if you have already checked this, it might something else.
> 
> Anything interesting in the Windows Eventlog / Samba Logfiles?
> 
> I only can say, that at work I have a Samba 4.1.7 AD, and it's no
> problem to RDP to machines joined to the domain with domain accounts.
> 
> 
> Regards,
> Marc
> 
Hello Marc,

I have just recognized, that if I shutdown samba4 on the DC, the client
is currently connected to, the login suddenly proceeds from the welcome
screen where it would otherwise have remained forever. I have tested it
with all three DCs and it is always the same result.

Do you have an idea what could be the cause of the problem, or can you
propose how I can troubleshoot in more detail ?

Thank you for your kind help

best regards

Andreas


More information about the samba mailing list