[Samba] Samba 4.1 Active Directory, Windows 2012 Standard Evaluation and Windows 2008 R2 Evaluation

Stuart Longland stuartl at vrt.com.au
Fri Mar 21 01:32:59 MDT 2014

On 21/03/14 11:09, Stuart Longland wrote:
> Going back to the OpenStack evaluation image of 2012 I had (which was
> the original 2012, not R2), it too reports that the password is incorrect.
> So it seems there's something odd with the way Windows 2008 R2 and
> Windows 2012 (original) that Samba4.1 doesn't like.  I'm doing a Windows
> Update on the 2008 R2 VM to see if that clears things up.
> If anyone else has ideas as to what I can check, that'd be appreciated.

Well, I've just done an update of the VM, and it still refuses to join
the domain.  Tried different domain admin accounts, carefully typing the
username and password in each case, turned off the firewall (there's no
firewall on the server and they're all on the same subnet).

No dice still.

I've cranked up logging in Samba to 10.  I've set the log file to
/var/log/samba/%m.log, however that just gives me a file literally named
/var/log/samba/%m.log (it appears the string substitution isn't
working), no files of the form /var/log/samba/${MACHINE_NAME}.log are

So rather than have Samba sort my logging out into separate files one
per machine as was with Samba 3.x, I now have a needle-in-a-haystack
search for information related to the errant computer that won't do as
it's told, amid a sea of logging messages from machines that are more
than happy to co-operate.

The following packages are installed on the domain controller:
> root at bnedevdc0:~# dpkg -l | grep samba
> ii  python-samba                        2:4.1.3+dfsg-2ubuntu3         amd64        Python bindings for Samba
> ii  samba                               2:4.1.3+dfsg-2ubuntu3         amd64        SMB/CIFS file, print, and login server for Unix
> ii  samba-common                        2:4.1.3+dfsg-2ubuntu3         all          common files used by both the Samba server and client
> ii  samba-common-bin                    2:4.1.3+dfsg-2ubuntu3         amd64        Samba common files used by both the server and the client
> ii  samba-dsdb-modules                  2:4.1.3+dfsg-2ubuntu3         amd64        Samba Directory Services Database
> ii  samba-libs:amd64                    2:4.1.3+dfsg-2ubuntu3         amd64        Samba core libraries
> ii  samba-vfs-modules                   2:4.1.3+dfsg-2ubuntu3         amd64        Samba Virtual FileSystem plugins
> ii  samba4                              4.0.3+dfsg1-0.1ubuntu4        amd64        dummy transitional package for samb  4.x series
I'm about to try an update of the entire OS to see if that fixes it.

I've tried joining the domain giving both the short name, and I've tried
with the full name.  Again, no dice.  Every time, I got my
correctly-entered password wrong, according to the would-be client.

Internet searches give me a wealth of information for Samba 3.x, all
useless when you're using version 4.1 to implement Active Directory.
They also give me a wealth of information on joining various versions of
Samba to a domain run by Windows servers: again useless when I want to
do the reverse.

I'll need to get this working in my test network first before I even
*think* about moving the main network off its Samba 3.5 domain, as we
have a couple of Windows 2008 R2 servers, and a whole fleet of Windows 7

As I understand it, this is basically the same OS... so if I can't get
2008R2 to work, I'm going to have hell with Windows 7.  Windows 2012/8
not working doesn't bother me, 2012r2 working is pleasing to know but
not essential, but 2008 R2 not working does trouble me greatly.

If anyone has any ideas where I should start looking, please let me know.
Stuart Longland
Systems Engineer
     _ ___
\  /|_) |                           T: +61 7 3535 9619
 \/ | \ |     38b Douglas Street    F: +61 7 3535 9699
   SYSTEMS    Milton QLD 4064       http://www.vrt.com.au

More information about the samba mailing list