[Samba] Dns update not working

Thomas Schulz schulz at adi.com
Thu Mar 6 10:10:59 MST 2014

> I joined a Fedora Linux box running Samba 4.1.5 to a Windows Server 2000
> domain controller as an additional domain controller with the command:
> samba-tool domain join adi.com DC -Uadministrator --realm=adi.com
>     --dns-backend=BIND9_DLZ
> The messages indicated that this was mostly sucessfull with the exception
> of the message:
> NO DNS zone information found in source domain, not replicating DNS
> Afterward I noticed that the Windows box had not added any new records in
> it's DNS and the samba log contains multiple errors about updating the DNS.
> I ran samba_dnsupdate --verbose to see what it would say and it listed
> many missing resords and then output errors about trying to add them.
> Here are three sample errors:
> Calling nsupdate for CNAME
>     ef382a43-092e-4cda-acb1-e7ba70e9253e._msdcs.adi.com koi.adi.com
> Outgoing update query:
> ;; ->>HEADER<<- opcode: UPDATE, status: NOERROR, id:      0
> ;; flags:; ZONE: 0, PREREQ: 0, UPDATE: 0, ADDITIONAL: 0
> ef382a43-092e-4cda-acb1-e7ba70e9253e._msdcs.adi.com. 900 IN CNAME koi.adi.com.
> dns_request_getresponse: FORMERR
> Failed nsupdate: 1
> ---------------------- lines removed --------------------------

Update. I went to the Windows DC and added the Samba DC to the group
DnsUpdateProxy. Now when I run samba_dnsupdate --verbose it says:

Reading domain information
Cannot create AD based DNS for OS level < 2003

So it looks like a Windows Server 2000 DC is not supported. I may have to
manually enter the records. I have just sent an email with the subject

How stable are DNS records

to see if I can find out if entering them manually will work.

Tom Schulz
Applied Dynamics Intl.
schulz at adi.com

More information about the samba mailing list