[Samba] can't get one specific group to show up in the output of id on one system but it does show up in another identically configured server in the same cluster

Sabuj Pattanayek sabujp at gmail.com
Sat Mar 1 06:19:30 MST 2014

this seems to have fixed itself after I added some write permission acl's
to a directory with the missing group using setfacl, I then connected via
smb from a windows system to the server that wasn't showing the group in
the output of id for the user, but was still able to create a file in that
directory. Running id on that user after this showed the missing group.

On Sat, Mar 1, 2014 at 6:42 AM, Sabuj Pattanayek <sabujp at gmail.com> wrote:

> updated to 4.1.5, rebooted the server, still no joy on getting that group
> to show up.
> On Fri, Feb 28, 2014 at 4:33 PM, Sabuj Pattanayek <sabujp at gmail.com>wrote:
>> net cache flush multiple times also hasn't helped, but I'm guessing
>> deleting all the files in /var/lib/samba is the same thing unless these
>> cache files are elsewhere?
>> On Fri, Feb 28, 2014 at 4:28 PM, Sabuj Pattanayek <sabujp at gmail.com>wrote:
>>> Hi all,
>>> I have two rhel 6.3 servers running sernet samba 4.1.4-7 with winbind
>>> connecting to AD. They're also running ctdb. For some very strange reason I
>>> can't get one specific AD group to show up in the output of "id username"
>>> or the gid of that group to show up in "wbinfo -r username" for the user on
>>> one of the servers but it shows up fine on the other. The strange part is
>>> that "getent group groupName" shows that the user in question belongs to
>>> the group on both systems.
>>> I've stopped, ctdb, smb, nmb, winbind, nscd deleted all the files out of
>>> /var/lib/samba, restarted all the daemons again and I'm still having the
>>> same problem. I've set persistent=off for groups in nscd and I've even
>>> tried it with nscd completely turned off and I still have the same problem
>>> where wbinfo -r, id, or the groups command  doesn't show one specific group
>>> for this user.
>>> Any ideas what's going on, how to debug this further?
>>> Thanks,
>>> Sabuj

More information about the samba mailing list