[Samba] DC replication not working

Günter Kukkukk linux at kukkukk.com
Sun Jun 15 10:01:20 MDT 2014

Am 13.06.2014 19:11, schrieb Steve Campbell:
> On 6/13/2014 12:27 PM, Günter Kukkukk wrote:
>> Am 13.06.2014 16:01, schrieb Steve Campbell:
>>> I've got a couple of Samba4 DCs running as VMs for testing. The primary AD DC went smoothly. The second VM joined properly and all but it's only when
>>> I get to the replication tests that I see errors. This is following the wiki
>>> When I run the command "samba-tool drs kcc -Uadministrator windowsdc.mycrap.cnpapers.dom" I get an error indicating that windowsdc.mycrap.cnpapers.dom
>>> is not found. Is "windowsdc" correct?
>>> When I run the command "samba-tool drs showrepl" I get a "DsReplicaGetInfo of type 0 failed NT_STATUS_RPC_PROTOCOL_ERROR" message.
>>> What step have I missed, please?
>>> steve campbell
>> Hi Steve,
>> please also tell us about
>>    - the *nix distro you are using
>>    - the samba version (as root: samba -V)
>>    - from where did you get the binaries (or did you built it yourself)
>>    - the overall AD topology (domain, realm, ...) you've configured
>> Cheers, Günter
> Thanks for the reply, but I think I have it solved (providing these were to be run on the active DC). I created a user and it was replicated, so on to
> more testing.
> steve

users which built samba from source - e.g. using the git tree -
and run more than one AD DC, should check for the python kcc:

  samba-tool testparm -v --suppress-prompt | grep kccsrv:samba_kcc

In case "true" is returned, one should disable the samba_kcc in
the [global] section of smb.conf:
        kccsrv:samba_kcc = false

The current implementation is not working correctly.

Cheers, Günter

More information about the samba mailing list