[Samba] DC replication not working

Steve Campbell campbell at cnpapers.com
Fri Jun 13 11:11:22 MDT 2014

On 6/13/2014 12:27 PM, Günter Kukkukk wrote:
> Am 13.06.2014 16:01, schrieb Steve Campbell:
>> I've got a couple of Samba4 DCs running as VMs for testing. The primary AD DC went smoothly. The second VM joined properly and all but it's only when
>> I get to the replication tests that I see errors. This is following the wiki
>> When I run the command "samba-tool drs kcc -Uadministrator windowsdc.mycrap.cnpapers.dom" I get an error indicating that windowsdc.mycrap.cnpapers.dom
>> is not found. Is "windowsdc" correct?
>> When I run the command "samba-tool drs showrepl" I get a "DsReplicaGetInfo of type 0 failed NT_STATUS_RPC_PROTOCOL_ERROR" message.
>> What step have I missed, please?
>> steve campbell
> Hi Steve,
> please also tell us about
>    - the *nix distro you are using
>    - the samba version (as root: samba -V)
>    - from where did you get the binaries (or did you built it yourself)
>    - the overall AD topology (domain, realm, ...) you've configured
> Cheers, Günter
Thanks for the reply, but I think I have it solved (providing these were 
to be run on the active DC). I created a user and it was replicated, so 
on to more testing.


More information about the samba mailing list