[Samba] DC replication not working

steve steve at steve-ss.com
Fri Jun 13 09:58:54 MDT 2014

On Fri, 2014-06-13 at 10:01 -0400, Steve Campbell wrote:
> I've got a couple of Samba4 DCs running as VMs for testing. The primary 
> AD DC went smoothly. The second VM joined properly and all but it's only 
> when I get to the replication tests that I see errors. This is following 
> the wiki
> When I run the command "samba-tool drs kcc -Uadministrator 
> windowsdc.mycrap.cnpapers.dom" I get an error indicating that 
> windowsdc.mycrap.cnpapers.dom is not found. Is "windowsdc" correct?
> When I run the command "samba-tool drs showrepl" I get a 
> "DsReplicaGetInfo of type 0 failed NT_STATUS_RPC_PROTOCOL_ERROR" message.
> What step have I missed, please?
> steve campbell
Hi Steve
Maybe you need to setup a software bridge to the actual interface. Some
guest vms NAT to the host by default so you end up with the same IP.

Also, can we tell if windowsdc is correct? This seems to be the start of
a new thread so we will not be able to tell if it's correct or not
without you telling us.


More information about the samba mailing list