[Samba] Question about adding DNS records

Bouke J. Henstra bouke at ict-diensten.com
Wed Jul 23 13:29:29 MDT 2014

Hello all,

I managed to install an extra DC.
The first DC is comsrv01a with ip
I run Samba 4.1.9 and BIND 9.8.1-P1.

The new DC is srv01ham with ip
I use the internal DNS.
I run Samba 4.1.9.

I use a permanent LAN-2-LAN VPN via my Draytek routers.
The first DC (comsrv01a, is my primary DNS server. This is
configured in all my routers and DHCP servers.

I followed the documents:
1. "Join a domain as a DC"
>> http://wiki.samba.org/index.php/Join_a_domain_as_a_DC
2. Samba AD DC HOWTO
>> http://wiki.samba.org/index.php/Samba_AD_DC_HOWTO

I would like to add the new DC to DNS.
I followed the information that I found at

Unfortunately I get the following error message.

root at comsrv01a:/opt/samba/bin# ./samba-tool dns add
th01.inet SRV01HAM A -Uadministrator
Password for [TH01\administrator]:
ERROR(runtime): uncaught exception - (9717,
  File "/opt/samba/lib/python2.7/site-packages/samba/netcmd/__init__.py",
line 175, in _run
    return self.run(*args, **kwargs)
  File "/opt/samba/lib/python2.7/site-packages/samba/netcmd/dns.py", line
1067, in run
    0, server, zone, name, add_rec_buf, None)

I would like to know how to fix this issue.
I found some information about this but I just can't get my head around.
Some indicate it is a bug and others write it has to do with RPC... I am
lost at this moment.

Also the log files don't lead me into the direction of a solution.
Help would be very much appreciated. Please let me know if I need to post
more details. Please help. I will reward you with beer or wine (when

Kind regards,


More information about the samba mailing list