[Samba] Replication and DNS issue

Donaldson Jeff Jeff.Donaldson at ncs.k12.de.us
Tue Jul 15 13:20:57 MDT 2014


I recently setup a new server to join an existing domain as a DC. I installed Ubuntu 12.04 server and downloaded and installed Samba 4.1.8. The installation went well and once completed I joined the domain with the following command - samba-tool domain join mydomain DC -Uadministrator --realm=mydomain (actual name changed). I got the Joined domain as a DC message. I followed the steps outlined in the Samba Join a Domain as DC wiki page to check required DNS entries. Running the host -t A server.domain returns the correct IP address. If I run the ldbsearch -H /usr/local/samba/private/sam.ldb '(invocationid=*)' --cross-ncs objectguid I see all three of my Domain controllers and their respective guids. I then ran the host -t CNAME guid._msdcs.mydomain command and found the msdc record wasn't added. I then used samba-tool to add it. It added correctly and the previous command now returns that the guid is an alias for the server. I then start Samba services without any errors. When I then check replication using samba-tool drs showrepl I have one inbound replication error and all outbound attempts fail. How can I get the new server to replicate to the existing DCs correctly (see txt attachment for showrepl results)?

The other issue I noticed is running DNS checks. If I run the host -t SRV _ldap._tcp.mydomain command, the newly joined DC doesn't appear. Same goes for the host -t SRV _kerberos._udp.mydomain. It does return correctly when running host -t A myserver.mydomain command. How can I correct the DNS entries? Kerberos appears to be working because I can kinit administrator and see the ticket. Any ideas?

I'm fairly new to Samba4, so please excuse my ignorance. Any help is appreciated!


Jeff Donaldson
Technology Director
Newark Charter School
jeff.donaldson at ncs.k12.de.us
(302) 369-2001 ext: 425
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: showrepl_output.txt
URL: <http://lists.samba.org/pipermail/samba/attachments/20140715/eae5e9d7/attachment.txt>

More information about the samba mailing list