[Samba] domain-based DFS ?

steve steve at steve-ss.com
Tue Jul 1 08:56:01 MDT 2014

On Tue, 2014-07-01 at 16:32 +0200, L.P.H. van Belle wrote:
> well.. 
> I just did a test with this for steve also. 
> same result. 
> \\domain.name\sysvol and netlogon accessable no problems. 
> \\domain.name\dfs   Access denied again? "Network path cannot be found...", 0x8xxxyy35? 
> \\server1.domain.name\dfs  works, but someshare not. 
> \\server1.domain.name\dfs\someshare 
> my steps. 
> mkdir -p /export/dfsroot
> chown root:root /export/dfsroot
> chmod 755 /export/dfsroot
> ln -s  'msdfs:mem1.internal.domain.tld\someshare' /export/dfsroot/someshare 
> also tried : ln -s  'msdfs:mem1.internal.domain.tld\\someshare' /export/dfsroot/someshare 
> smbclient //localhost/dfs  -U 'administrator' 
> cd someshare
> tree connect failed: NT_STATUS_BAD_NETWORK_NAME
> Unable to follow dfs referral [\mem1.internal.domain.tld\]
> cd \somewhare\: NT_STATUS_BAD_NETWORK_NAME
> so far for me.. 
> found this one
> https://groups.google.com/forum/#!topic/linux.samba/mi4O5lHE8Vc 
> so i think this is not fixed yet... 
> there is a patch in this link, but since im on sernet im not trying the patch. 

Yeah, thanks Louis.
This is looking more and more like a time consuming, undocumented dead
end. I'm really tempted to drop it at this point and spend the time on a
proper cluster instead. I get the feeling that this was always going to
be second best, and it only works with windows clients anyway.

More information about the samba mailing list