[Samba] Configuring RHEL6 Samba4 DC for local accounts

Paul R. Ganci ganci at nurdog.com
Sun Jan 26 19:53:02 MST 2014

On 01/26/2014 03:27 PM, Rowland Penny wrote:
> Is your DC really called ad.example.com or is it 
> hostname.ad.example.com? either way I do not think your sssd.conf is 
> going to work, also is there any chance you can update sssd to the 
> latest 1.11 series?
This is exactly the exercise I tried (see the thread begun on 
10/22/2013: User home directory UID:GID incorrect on VM Samba 4 AD). I 
was trying to get SSSD on a CentOS 6.4 system to work with the Sernet 
samba packages. While I had no install issues and with a lot of agony 
kind of got things like client logon authentication to work there were 
other things that broke (which will be broke in RHEL 6 too). I tried to 
compile the latest version of SSSD but there are just too many 
dependencies of required code that is too old that it is impossible IMHO 
to get a recent version of SSSD to compile (at least not without 
upgrading significant pieces of the disto). That is why I stuck with 
winbind. That seemed to work with the old but stable software found on 
CentOS 6.4 (RHEL 6 clone). I would be very interested to know if anyone 
successfully compiled SSSD on RHEL 6 (or RHEL 6 clone) and/or ever got 
SSSD to work with the Sernet Samba packages on RHEL 6 (or RHEL 6 clone).

Paul (ganci at nurdog.com)

More information about the samba mailing list