[Samba] gpfs + sernet samba + ctdb + transparent failover confusion

Sabuj Pattanayek sabujp at gmail.com
Thu Jan 23 15:19:29 MST 2014

Hi all,

We're running gpfs (5 total nsds & quorum servers, 2 nsds running
samba), sernet-samba 4.1.4-7, and ctdb and trying to get
transparent failover to work from a windows 8 client. We have ctdb failover
working, i.e. if I run mmshutdown on one of the nodes the IPs failover in a
few seconds after the GPFS mount is unmounted. For our transparent failover
test, I open up firefox and start downloading a large file, e.g. a centos
6.5 iso into the mapped network drive being served up by one of the samba
servers. Then I run an "mmshutdown" on the samba server the client is
connected to and as soon as the mount disappears on the server the download
stops and firefox throws an error. I was expecting that with transparent
failover that the download would "hang" until the IPs had a chance to
failover and the download/writes would continue but that didn't seem to

Any idea on how to get this to work? Do we need to use ctdb 2.5.1? What's
the difference between the sernet-samba provided ctdb 1.0.114 and the ctdb
2.5.1 line ? I tried to install the samba.org provided ctdb 2.5.1 RPMs but
it failed with :

ctdb >= 1.0.115 conflicts with sernet-samba-4.1.4-7.el6.x86_64

I also created rpm's using the spec file from the ctdb-2.5.1 sources and
got the same error. Looks like using "make install" would be the only way
to get this installed, but even then why is sernet-samba requireing the
1.0.x line? Again, does it even matter with the original issue with
transparent failover?


More information about the samba mailing list