[Samba] Samba Xattr and Execute Bit always set.

steve steve at steve-ss.com
Wed Jan 22 07:20:39 MST 2014

On Wed, 2014-01-22 at 12:58 +0100, Prunk Dump wrote:
> Hello,
> Please help me. I have tried many solutions but none have solved my problem...
> Files created on my server through a samba-4.1.4 share always have
> their execute bit set :
> ---------------------
> ls -l /fichsamba/smbhome/teachers/pellegrb/
> total 36
> -rwxrwxr-x+ 1 FICHNET\pellegrb FICHNET\teachers 8745 janv. 17 18:10 test.txt
> ---------------------
> This is problematic because I also share this directory for linux users.

That file was created on a windows machine and is stored on a samba
server. The -rwxrwxr-x+ bears no resemblance to the actual permissions
in Linux. If you have set 0644 then that's how it will behave if you
mount it correctly on a Linux client or on the server where the file is

Maybe the best way to prove this to your boss is to log in _on the file
server_ as a domain user other than pellegrb but still a member of the
teachers group. Now try to edit test.txt You can't.

Or, create a bash script in the same share in windows and try to execute
it on the file server. You can't.

More information about the samba mailing list