[Samba] Samba Xattr and Execute Bit always set.

Prunk Dump prunkdump at gmail.com
Wed Jan 22 04:58:35 MST 2014


Please help me. I have tried many solutions but none have solved my problem...

Files created on my server through a samba-4.1.4 share always have
their execute bit set :

ls -l /fichsamba/smbhome/teachers/pellegrb/
total 36
-rwxrwxr-x+ 1 FICHNET\pellegrb FICHNET\teachers 8745 janv. 17 18:10 test.txt

This is problematic because I also share this directory for linux users.

-> I have tried to set :
map archive = no
map hidden = no
map system = no

But it seems useless because there attributes are now stored in the
file system xattr user.DOSATTRIB.

-> I have tried to set :
create mask = 0644

But the options seems to be ignored...

If the file system support ACLs and Xattr, what is the usage of the
Unix execute bits on samba in the DOS modes <-> UNIX permissions
mapping ? How can I keep UNIX compatibility on my samba share ?

Thank you very much !


More information about the samba mailing list