[Samba] error while mount/access DFS share

Carlos Baptista cbaptista at opensuse.us
Fri Jan 17 11:28:44 MST 2014


I'm having an error trying to read the contens of a DFS Share

The mount is:
    sudo mount -t cifs -o username=mxxxxx ,uid=mxxxxx,gid=mxxxxx
//cluster_share/share /mnt

The share is mounted without errors, but when I try to list the share i
have this:
    ls -la /mnt/folder
    ls: cannot open directory /mnt/folder: Operation now in progress

and the syslog have the error reported

    Jan 17 18:10:16 cb kernel: [36071.245615] CIFS VFS: Autodisabling
the use of server inode numbers on \\cluster_server\share. This server
    doesn't seem to support them properly. Hardlinks will not be
recognized on this mount. Consider mounting with the "noserverino"
option     to silence this message.
    Jan 17 18:10:28 cb kernel: [36084.046828] CIFS VFS: Error connecting
to socket. Aborting operation.
    Jan 17 18:10:28 cb kernel: [36084.047077] CIFS VFS: cifs_mount
failed w/return code = -115

The server with the DFS namespace is a Windows 2008 R2 with file cluster
The DFS is:
        \\cluster_server\share  -> namespace
                \\cluster_server\share\folder  ->  \\nas\folder
                \\cluster_server\share\folder01 - \\nas\folder01

The option "noserverino" was tried, but with the same result.

smbclient --version
Version 3.6.18

Any suggestion?


Carlos Baptista


More information about the samba mailing list