[Samba] pam_winbind fails to authenticate domain users on my debian wheezy domain member servers

Peter Schaefer peter.schaefer at gmx.de
Wed Jan 8 14:51:06 MST 2014

Am 1/8/2014 9:00 PM, Rowland Penny wrote:
> I fail to see how you got sssd to install on wheezy, I installed the sernet packages, these removed the standard samba 
> packages and then once the sernet packages were installed and I couldn't get winbind to work correctly I tried to 
> install sssd. I found that sssd would not install because it depends on the samba packages that the sernet packages 
> removed.

Well, sssd does not depend on any samba-package directly (see below). You might been hit by some indirect dependency 
that i don't have. I used the MIT kerberos packages, maybe you used the "Heimdal" versions, but i'm not sure if this 
would cause collisions.

And i'm not installing the "Suggest"-packages.

~# dpkg -s sssd

Package: sssd
Status: install ok installed
Priority: extra
Section: utils
Installed-Size: 7727
Maintainer: Debian SSSD Team <pkg-sssd-devel at lists.alioth.debian.org>
Architecture: amd64
Version: 1.8.4-2
Depends: libc-ares2 (>= 1.7.0), libc6 (>= 2.4), libcollection2, libcomerr2 (>= 1.01), libdbus-1-3 (>= 1.1.1), libdhash1, 
libini-config2, libipa-hbac0 (= 1.8.4-2), libk5crypto3 (>= 1.6.dfsg.2), libkeyutils1, libkrb5-3 (>= 1.9+dfsg~beta1), 
libldap-2.4-2 (>= 2.4.7), libldb1 (>= 0.9.21), libnl1 (>= 1.1), libnspr4 (>= 2:4.9-2~) | libnspr4-0d (>=, 
libnss3 (>= 2:3.13.4-2~) | libnss3-1d (>= 3.12.0~1.9b1), libpam0g (>=, libpcre3 (>= 8.10), libpopt0 (>= 1.14), 
libtalloc2 (>= 2.0.4~git20101213), libtdb1 (>= 1.2.7+git20101214), libtevent0 (>= 0.9.9), libunistring0, python, python-sss
Pre-Depends: multiarch-support
Recommends: ldap-utils, bind9-host, libnss-sss, libpam-sss, libsasl2-modules-gssapi-mit | 
libsasl2-modules-gssapi-heimdal, libsasl2-modules-ldap
Suggests: apparmor, sssd-tools

> You can hold your breath if you like, sssd 1.11.3 is in Ubuntu 14.04 beta (there is also an active ppa) and 14.04 has 
> not yet been frozen.

I'm not saying that it's not in Trusty. All i'm saying is (according to the list at 
http://packages.ubuntu.com/trusty/allpackages?format=txt.gz) it's in "Universe" and the LTS 5-year-update-guarantee does 
not cover "Universe".


More information about the samba mailing list