[Samba] pam_winbind fails to authenticate domain users on my debian wheezy domain member servers

Rowland Penny rowlandpenny at googlemail.com
Wed Jan 8 13:00:18 MST 2014

On 08/01/14 19:36, Peter Schaefer wrote:
> Am 1/8/2014 11:41 AM, Rowland Penny wrote:
>> Hi, just to say that I set up debian wheezy in a VM and then setup 
>> sernet-samba as the OP did and I could not get winbind to work, I 
>> tried everything that I could think of but to no avail. I then tried 
>> to install sssd instead, but it would seem that if you are using the 
>> sernet samba packages you cannot install sssd. So, at risk of 
>> upsetting Sernet, I cannot recommend their packages at all until they 
>> stop naming them sernet-*. 
> What makes you think of that? I'm running these just fine:
> ii  sernet-samba                          99:4.1.3-7
> ii  sernet-samba-ad                       99:4.1.3-7
> ii  sernet-samba-client                   99:4.1.3-7
> ii  sernet-samba-common                   99:4.1.3-7
> ii  sernet-samba-libs:amd64               99:4.1.3-7
> ii  sernet-samba-libsmbclient0:amd64      99:4.1.3-7
> ii  sernet-samba-winbind                  99:4.1.3-7
> ii  sssd                                  1.8.4-2
> ii  sssd-tools                            1.8.4-2

I fail to see how you got sssd to install on wheezy, I installed the 
sernet packages, these removed the standard samba packages and then once 
the sernet packages were installed and I couldn't get winbind to work 
correctly I tried to install sssd. I found that sssd would not install 
because it depends on the samba packages that the sernet packages removed.

>> But all is not lost, Ubuntu 14.04 will have sssd 1.11.3 and, at the 
>> moment, Samba 4.0.13 and with a bit of luck will get Samba 4.1.3 
>> (this is in Jessie now). so with 5 years of updates, this will make a 
>> better platform than Debian Wheezy.
> I won't hold my breath. Ubuntu LTS guarantees timely security updates 
> only for packages in "main" and "restricted"; packages in other suites 
> rely on "community" support and many of them have a bad track record 
> regarding this, unfortunately. Samba generally is in "main", but sssd 
> is only in "universe", AFAIK.

You can hold your breath if you like, sssd 1.11.3 is in Ubuntu 14.04 
beta (there is also an active ppa) and 14.04 has not yet been frozen.


> Regards,
>   Peter

More information about the samba mailing list