[Samba] Windows 8.1 64-bit printer sharing issue

Philipp v. Thunen phil_lists at pvth.de
Thu Feb 27 10:24:04 MST 2014


having seen this error on some (but not all) of my Win8.1 64-bit
machines, it helped to set the following reg key on the client [1]:

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Printers]

Alternatively, set the policy "Always render print jobs on the server"
to "Disabled" via GPO to avoid touching the registry on every client.
Both worked fine for me, hope it helps for you, too.


[1] Credits to

Am 27.02.2014 15:22, schrieb Antoine Benkemoun:
> We have setup a Samba 4.1.0 server that has worked great so far.
> We have a printer share that is set up so that our users  access the printers around the office directly via a central location. It is setup so that the users' computers can get the driver directly from the print server. We use CUPS to manage the printers. It is deployed via GPO.
> It works great for Windows 7 32-bit and 64-bit as well as Windows 8.1 32-bit.
> We are encountering problems with Windows 8.1 64-bit. The driver installation works successfully as we can see the driver on the client computer.
> Despite this, when we try to access the shared printer we get the following error : "Operation failed with error 0x000006d1". We get the same error with every shared printer we have available on that server.
> I have attached to this email the Samba associated produced when trying to access the printer. IP's starting in "127.0" are just for obfuscation. The actual log has the correct IPs of the server and client.
> What parameters can we modify to enable this compatibility with Win8.1 64-bit ? Is this a known limitation of the version we are using ? Has somebody been able to share printers with Win8.1 64-bit successfully ?
> I would be more than happy to provide more information should it be needed.

More information about the samba mailing list