[Samba] NT_STATUS_OBJECT_NAME_NOT_FOUND after installing the last git version

Andrew Bartlett abartlet at samba.org
Tue Feb 18 01:13:35 MST 2014

On Mon, 2014-02-17 at 23:21 +1100, Alain Foucher wrote:
> I have installed many different versions of Samba4 with success.
> Now, i would install a new one with the git tool on an ubuntu 12.04.
> I did the git clone with success.
> The configure, make and make install ran with success.
> I ran the provisioning  command with success :
>  /usr/local/samba/bin/samba-tool domain 
> provision --use-rfc2307 --interactive
> I test Kerberos and DNS (kinit, klist, host commands) without any problem.
> In the log.samba and the log.smbd, i've got no error, Everything seems to be 
> allright (samba-tool dbcheck, wbinfo, ...).
> But when i run the following command
> smbclient -L localhost -U%               (or any smbclient command)
> i've got this message
> session setup failed: NT_STATUS_OBJECT_NAME_NOT_FOUND
> The version, i installed is the followin one :
>                         Version 4.2.0pre1-GIT-001b958
> Did i miss some issues ?

Thank you very much for bringing this to our attention. 

This is a (now) know regression that appears to have been introduced
recently with the change to use wbc_xids_to_sids.  Garming and I were
able to isolate it down to one of these commits at the end of our work
day today:

6b04558c5e0547a807ac0fcb5eeb1085cfe602ac auth4: Remove unused wbc_context
f35f88d741f1f896268649238d4ddbda4abb1585 ntvfs_unixuid: No wbc_context required
55dd08c4e80827ffc4fe423f3e67aec499af06df ntvfs_posix: No wbc_context required
5a4252789b54b6b270b3083f6e0732ba1fdd774b dcesrv_unixinfo: No wbc_context required
25e83a9b3e72cdb84c09ef8ada4784efd110f09a unixuid: Use the tevent_context from the ntvfs_context
15700a9f6e5393cecf78052f510e015300c5bd85 pvfs: Use the tevent_context from the ntvfs_context
5124a9e1183de990ca3146cd355152094495a779 auth4: Do not generate just a temporary wbc_context
75d7c4609c1c743f84ca9f2d0666aece9e5200d4 auth4: auth_session_info_fill_unix only needs a tevent_context
1de725c2926b526200032c4f46132c17533986c7 auth4: security_token_to_unix_token only needs a tevent_context
ba5f02739cb454d2312f73f643f2c119e090ac5e libwbclient4: Remove unused composite-based functions
d0932a1ae089fda0d41be21a9916caeca7c0c233 source4: Use wbc_xids_to_sids
f275ce4e4367478b488810491c7bcd993c37caf1 libwbclient4: Add wbc_xids_to_sids
de7122ddc356697777cce95d22b3fab7697b30db source4: Use wbc_sids_to_xids
fefc59619b58cb0c38bf7e6ac2ebcc25a5ebbd6c libwbclient4: Add wbc_sids_to_xids

I expect to further diagnose this tomorrow, but in the meantime I've
CC'ed the patch author and reviewer in case they have any insights. 

In the meantime, you could assist by reverting each of these patches in
turn, and verifying that it does indeed resolve your issue. 


Andrew Bartlett

Andrew Bartlett                       http://samba.org/~abartlet/
Authentication Developer, Samba Team  http://samba.org
Samba Developer, Catalyst IT          http://catalyst.net.nz/services/samba

More information about the samba mailing list