[Samba] Slow Samba transfer

L.P.H. van Belle belle at bazuin.nl
Fri Feb 14 01:50:59 MST 2014


what i forgot, om only getting the 110Mb/s + because of format. 
I formatted with 4Mb block size, since this is a Movie share on my server.
the "normal" music share are 1Mb blocks formated.  ( about 80-100Mb/s ) 
all my other default.  ( variable from about 60-100Mb/s ) 

and on debian you can do a  apt-get install iotop
and type iotop, to see you read/write speeds on the server and which apps are working.


>-----Oorspronkelijk bericht-----
>Van: dcmwai at gmail.com [mailto:samba-bounces at lists.samba.org] 
>Namens Chan Min Wai
>Verzonden: vrijdag 14 februari 2014 9:37
>Aan: Mauro Condarelli
>CC: samba at lists.samba.org
>Onderwerp: Re: [Samba] Slow Samba transfer
>Dear Mauro,
>if you are using the latest version on samba 3.x and above (as 
>I can recall)
>I would advise you to drop all the socket options and etc...
>The new version of samba with the new linux kernel are able to 
>adjust that
>without much adjustment...
>However, since your are behind the vm...
>you might want to try a small fio test to see if the limit was 
>vm or etc...
>Hope this help...
>On Fri, Feb 14, 2014 at 7:51 AM, Mauro Condarelli 
><mc5686 at mclink.it> wrote:
>> Hi,
>> this is my first pos here, please be lenient.
>> My problem shuld be a FAQ and, in fact I found a lot of references
>> googling around, but nothing could really solve my problem, 
>so here I am.
>> I have a Samba server:
>> Very basic wheezy amd64 installation on a small VIRTUAL server (Xen).
>> Only fancy thing is direct access to a couple of RAID1 
>(mirror) arrays
>> where data is stored.
>> I normally access data from Windows (mostly Seven) machines connected
>> either via ethernet GB hub (but some machines are 100MB) or 
>via WLan(N).
>> Problem is throughput is generally low (about 1 mb/s) and, 
>for really big
>> files (> 1Gb) it drops with time going to the range of few 
>hunderd kb/s.
>> Transferring a 4Gb file takes HOURS.
>> I do not believe it's normal, is it?
>> I started with the plain wheezy-provided setup and tried to 
>improve it
>> following several advices found around the net, but I did not see any
>> difference.
>> Things I tried are:
>>    strict allocate = yes
>>    read raw = yes
>>    write raw = yes
>>    strict locking = no
>>    socket options = TCP_NODELAY IPTOS_LOWDELAY SO_RCVBUF=65536
>>    min receivefile size = 16384
>>    use sendfile = true
>>    aio read size = 1
>>    aio write size = 1
>> ;   vfs objects = aio_fork
>> in various combinations.
>> Last option does not seem to be supported in Wheezy:
>> [2014/02/14 00:47:09.185334,  0] smbd/vfs.c:173(vfs_init_custom)
>>   error probing vfs module 'aio_fork': NT_STATUS_UNSUCCESSFUL
>> [2014/02/14 00:47:09.185397,  0] smbd/vfs.c:315(smbd_vfs_init)
>>   smbd_vfs_init: vfs_init_custom failed for aio_fork
>> [2014/02/14 00:47:09.185440,  0] 
>>   vfs_init failed for service IPC$
>> What should I do?
>> Thanks in Advance
>> Mauro
>> --
>> To unsubscribe from this list go to the following URL and read the
>> instructions:  https://lists.samba.org/mailman/options/samba
>To unsubscribe from this list go to the following URL and read the
>instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list