[Samba] Slow Samba transfer

Mauro Condarelli mc5686 at mclink.it
Thu Feb 13 16:51:02 MST 2014

this is my first pos here, please be lenient.
My problem shuld be a FAQ and, in fact I found a lot of references 
googling around, but nothing could really solve my problem, so here I am.

I have a Samba server:
Very basic wheezy amd64 installation on a small VIRTUAL server (Xen).
Only fancy thing is direct access to a couple of RAID1 (mirror) arrays 
where data is stored.

I normally access data from Windows (mostly Seven) machines connected 
either via ethernet GB hub (but some machines are 100MB) or via WLan(N).

Problem is throughput is generally low (about 1 mb/s) and, for really 
big files (> 1Gb) it drops with time going to the range of few hunderd kb/s.

Transferring a 4Gb file takes HOURS.

I do not believe it's normal, is it?

I started with the plain wheezy-provided setup and tried to improve it 
following several advices found around the net, but I did not see any 

Things I tried are:

    strict allocate = yes
    read raw = yes
    write raw = yes
    strict locking = no
    socket options = TCP_NODELAY IPTOS_LOWDELAY SO_RCVBUF=65536 
    min receivefile size = 16384
    use sendfile = true
    aio read size = 1
    aio write size = 1
;   vfs objects = aio_fork

in various combinations.
Last option does not seem to be supported in Wheezy:

[2014/02/14 00:47:09.185334,  0] smbd/vfs.c:173(vfs_init_custom)
   error probing vfs module 'aio_fork': NT_STATUS_UNSUCCESSFUL
[2014/02/14 00:47:09.185397,  0] smbd/vfs.c:315(smbd_vfs_init)
   smbd_vfs_init: vfs_init_custom failed for aio_fork
[2014/02/14 00:47:09.185440,  0] smbd/service.c:902(make_connection_snum)
   vfs_init failed for service IPC$

What should I do?
Thanks in Advance

More information about the samba mailing list