[Samba] force group does not work

Leander S. info at netocean.de
Sun Feb 9 10:27:51 MST 2014

Am 09.02.14 14:47, schrieb Jonathan Buzzard:
> On 08/02/14 09:35, Leander S. wrote:
>> Hi
>> I set up a samba 4.1.4 server on the latest FreeBSD RELEASE 10.
>> Unfortunately it doesn't seem to consider the option force group. After
>> hours ofresearch I couldn't figure out what I'm still missing. unix
>> extensions is set to no. Setting the debug level up to 10 also didn't
>> help ;(
>> Is this a bug or is there simply a mistake in my setup?
> You don't say what your clients are? In my experience the number one 
> reason force group does not work is because you have Mac OSX clients 
> and unix extensions enabled.
> JAB.

thanks for your input. I've tried it via

  * smbclient -U MyUser \\\\${SERVERNAME,,}\\MyShare <password>
  * as well as I tried it with my MacOSX client
  * as well as I tried it with my Windows7 client

unfortunately all results in the same.
A couple of posts before, I've published my smb4.conf. I've already set 
'unix extensions' to 'No', otherwhise

   create mask          = 0770
   force create mode    = 0770
   directory mask       = 0770
   force directory mode = 0770

will also be ignored.

More information about the samba mailing list