[Samba] Can't get permission on a share to work problem with groups

Horace mailinglist at lhplan.tk
Sun Feb 9 03:45:03 MST 2014

On 2014-02-09 05:04, Chan Min Wai wrote:
> Dear Horace,
> Just wonder if this share server is also a DC?
> also if your getent passwd "usersname" would work?
> On Sun, Feb 9, 2014 at 5:01 PM, Horace <mailinglist at lhplan.tk> wrote:

Yes, the Share Server is the PDC on the network. I don't have the box 
setup to auth with Winbind (or AD). So if I ran 'getent passwd 
"usersname"', it would just list the username in /etc/passwd. Although, 
the group 'Domain Admins' does exists in /etc/group:

Domain Admins::1003:lutchy.horace

One of the things I did notice is 'is a None' and when I run 'net lookup 
name "ACCOUNTSAD\Domain Admins"':

S-1-5-21-2464428415-236237825-3255720288-512 0 (None) ACCOUNTSAD\Domain 

and saw a difference with 'net lookup name "ACCOUNTAD\lutchy.horace"':

S-1-5-21-2464428415-236237825-3255720288-1107 1 (User) 

And noticed (User), I wonder if there is a 'Type' and if that 'Type' 
needs to be set to 'Group'. :/

More information about the samba mailing list