[Samba] Odd Samba/btrfs AD member server problem - SOLVED

Moby moby at mobsternet.com
Mon Dec 29 22:14:28 MST 2014

On 12/29/2014 11:09 PM, Moby wrote:
> On 12/29/2014 07:34 PM, Moby wrote:
>> openSUSE 13.2 machine with btrfs for /
>> Running samba-4.1.14-3.3.x86_64.
>> Samba is configured to have the server act as a member server in a 
>> Windows Activedirectory domain.
>> wbinfo -u and getent passwd work fine.  getent passwd shows local and 
>> domain users.
>> However, setfacl -n -R -m u:userX:rwx /testpath fails if userX is a 
>> domain user, but succeeds if userX is a local user.  Using different 
>> specifications for userX ('domain\userX') still fail.
>> Same testing, with almost identical smb.conf and other settings, 
>> works just fine on a opensuse 13.1 machine with ext4 running 
>> samba-4.1.14-3.2.i586
>> Any ideas or help in resolving the failure on opensuse 13.2 are much 
>> appreciated.
> Just tried wbinfo, getent etc all work for users and groups, the 
> command id <domain user> fails with No such user.  Not sure what that 
> adds, but just found that out.
Restarting nscd fixed it!  I stopped nscd, then restarted smb, winbind, 
and nmb, and everything started working.  Then I started nscd and 
everything is still working.


They that can give up essential liberty to obtain a little temporary safety deserve neither liberty nor safety.  -- Benjamin Franklin

More information about the samba mailing list