[Samba] howto install sudo schema

shadrock uhuru niyalevi at gmail.com
Thu Aug 21 12:57:26 MDT 2014

Hi all

> OK, if I replace the the path to sam.ldb & the rootdse (the dc= part) on 
> the ldbedit command it works, so something is going wrong on your 
> system, so:
> What OS
> What version samba4
> compiled or distro package
> what version ldbtools
> You need --kerberos to actually change anything, searching is different.
> Rowland

$ uname -a
Linux ashanti 3.15.5-2-ARCH #1 SMP PREEMPT Fri Jul 11 07:55:51 CEST 2014
i686 GNU/Linux
$ samba -V
Version 4.1.9
$ ldbedit -V
Version 4.1.9
$ ldbsearch -V
Version 4.1.9
$ samba-tool -V

samba was installed from a package with the standard command of #pacman
-S samba.

i tried
$ sudo ldbedit -e nano -H /etc/samba/private/sam.ldb -b
this brought up the editor with this to edit

# editing 1 records
# record 1
dn: cn=%wheel,ou=SUDOers,DC=tissisat,DC=co,DC=uk
cn: %wheel
objectClass: top
objectClass: sudoRole
sudoCommand: ALL
sudoHost: ALL
sudoUser: %wheel
distinguishedName: cn=%wheel,ou=SUDOers,DC=tissisat,DC=co,DC=uk

i then tried this
$ sudo ldbedit -e nano -H /etc/samba/private/sam.ldb -b
OU=SUDOers,dc=tissisat,dc=co,dc=uk -s sub
no matching records - cannot edit


More information about the samba mailing list