[Samba] auth methods = winbind

Ryan Ashley ryana at reachtechfp.com
Fri Aug 15 17:49:24 MDT 2014

Mr. Bartlett, I did not expect to see you involved in this thread. Your 
posts have helped me countless times over the years and it is my 
pleasure to actually thank you for your work with Samba and the 
community. I also apologize for my loss of control last night after 
repeated sarcastic responses and such from other members.

Now, if you look at my email posted at 10:13 this morning, linked below, 
you will see that I do not use that "auth methods" setting. The quote 
you're using is from last month, when I was still using it. I know I 
have posted my configuration file a dozen times, but I removed that line 
a week ago when Rowland informed me (twice actually, I forgot to the 
first time) that I should not use it. I have seen many people helped by 
Rowland and he has taught me a lot over the past few weeks. I am sure he 
is tired of trying to help me with the problem, but thankfully it is 
solved now. He did teach me about the Kerberos keytab and I intend on 
using it from now on. He also taught about the auth methods and even 
straightened me out on using the Samba packages in the backports 
repository of my Linux distro. He's a very knowledgeable person.


I am still not sure how I got under Steve's skin, but I do appreciate 
the help he offered me. I fully intend to continue using Samba in my 
environments and should I have another issue in the future I will drop 
by again. Then again, I have been using Samba since version 2 and this 
is the first thing that stumped me, and it turns out it was a stupid 
permissions issue! I even remember changing the permissions, but it was 
while Samba was running. My guess is that it continued to work and when 
the server was rebooted, it started acting up. Either way, I will be 
changing the file permissions on the print-server to 755 soon and if it 
fixes it, I'll get out of everybody's hair.

I do want to thank everybody who helped me. I bear no hard feelings 
towards any of you. I was under a lot of stress to fix this and I am 
sure you got tired of my emails filling your inboxes. Steve, Rowland, 
and Gregory, I hope you can forgive whatever I did to annoy you. Achim, 
I owe you. If I can do anything for you, just ask. You solved my problem 
in your first response to my thread. Thanks!

On 8/15/2014 5:23 PM, Andrew Bartlett wrote:
> On Thu, 2014-07-24 at 11:25 -0400, Ryan Ashley wrote:
>> I have been using Samba4 for ages and love it as a DC and a
>> print-server. I just setup my first member-server designed solely to
>> host file shares, and have hit an issue. Group policy is mapping it
>> correctly for the users in the group, but those users are getting an
>> access denied message from their Windows 7 Pro 64bit clients when
>> accessing the share. I have configured ACLs and the box resolves users
>> and groups. Everything works, except for the shares. Below I attached
>> all of the information I believe to be useful. Ask if you need more, and
>> thank you for your help!
>> smb.conf:
>> ======
>> [global]
>>     auth methods = winbind
> Ryan,
> I know you have had much advice, a lot of it not actually relevant to
> the problems you have at hand (I see you have been distracted down
> 'kerberos method' for example), and this advice is probably in the same
> category.
> However:  Please do not set 'auth methods'.  It has already been set
> correctly by the defaults (based on security=), and the parameter only
> needs to be set in the most unusual of configurations.
> Yes, it will probably still work (perhaps breaking anonymous access,
> which you probably are not using), but the man-page does say:
> "This should be considered a developer option and used only in rare
> circumstances.  In the majority (if not all) of production servers, the
> default setting should be adequate."
> Thanks,
> Andrew Bartlett

More information about the samba mailing list