[Samba] Problem to demote Samba4 DC

Davy HUBERT davy.hubert at univ-montp3.fr
Tue Sep 24 05:36:33 MDT 2013


I recently migrated our samba 3 domain to an AD domain using Samba 4 
classic upgrade tool.
DNS is provided by the internal dns server of Samba 4.

I promoted a Windows 2k8 box as a new DC of this domain and I transfer 
all the 5 FSMO roles to this windows box.

Now I would like to demote the Samba4 DC but when I tried I got this 
message :

# samba-tool domain demote
ERROR: Current DC is still the owner of 2 role(s), use the role command 
to transfer roles to another DC

When check the fsmo roles status via "samba-tool fsmo show" on linux or 
with ntdsutil on windows it confirms that the Samba 4 DC doesn't own 

Then, I tried to just stop samba4 and follow the microsoft procedure to 
remove a failed DC. But when I do that the domain fails, i've got an 
error message when i try to open any AD tool (ADUC for example) saying 
that the "domain cannot be found".

It seems that something is handled by Samba only but I can't figure out 

Is this a DNS problem ? Should I use Bind ?

Well, it's not urgent... wait a minute, my boss has a chainsaw, maybe I 
should hurry :D .

Best regards,

DSI/SMI - Unité Systèmes
Université Paul-Valéry, Montpellier 3
davy.hubert at univ-montp3.fr

More information about the samba mailing list