[Samba] gpresult returns "ERROR: The RPC server is unavailable."

Kevin Field kev at brantaero.com
Sat Sep 21 18:08:27 MDT 2013


I have a CentOS 6.4 box running SerNet Samba 4.0.9 as an AD DC 
replicating from a W2k3 box.

If I run "gpresult /s OLDDC /user MYDOM\Me" on a command prompt on 
OLDDC, I get a normal output, listing which GPOs are applied.

If I run "gpresult /s NEWDC /user MYDOM\Me" in the same place, I get 
"ERROR: The RPC server is unavailable."  This is after a fresh restart 
of Samba.

log.samba says (starting at last restart):

   samba: using 'standard' process model
[2013/09/21 20:01:30.191185,  0] ../source4/smbd/server.c:121(sig_term)
[2013/09/21 20:01:30.191208,  0] ../source4/smbd/server.c:121(sig_term)
[2013/09/21 20:01:30.191223,  0] ../source4/smbd/server.c:121(sig_term)
[2013/09/21 20:01:30.191223,  0] ../source4/smbd/server.c:121(sig_term)
   Exiting pid 30885 on SIGTERM
   Exiting pid 30882 on SIGTERM
[2013/09/21 20:01:30.191221,  0] ../source4/smbd/server.c:121(sig_term)
[2013/09/21 20:01:30.191225,  0] ../source4/smbd/server.c:121(sig_term)
   Exiting pid 30877 on SIGTERM
   Exiting pid 30876 on SIGTERM
   Exiting pid 30879 on SIGTERM
   Exiting pid 30880 on SIGTERM
[2013/09/21 20:01:30.191674,  0] ../source4/smbd/server.c:121(sig_term)
   Exiting pid 30878 on SIGTERM
[2013/09/21 20:01:30.194399,  0] ../source4/smbd/server.c:121(sig_term)
   Exiting pid 30881 on SIGTERM
[2013/09/21 20:01:30.201604,  0] ../source4/smbd/server.c:121(sig_term)
[2013/09/21 20:01:30.201604,  0] ../source4/smbd/server.c:121(sig_term)
[2013/09/21 20:01:30.201685,  0] ../source4/smbd/server.c:121(sig_term)
[2013/09/21 20:01:30.201685,  0] ../source4/smbd/server.c:121(sig_term)
   Exiting pid 30871 on SIGTERM
   Exiting pid 30874 on SIGTERM
[2013/09/21 20:01:30.201713,  0] ../source4/smbd/server.c:121(sig_term)
   Exiting pid 30873 on SIGTERM
   Exiting pid 30872 on SIGTERM
   Exiting pid 30875 on SIGTERM
[2013/09/21 20:01:30.213640,  0] ../source4/smbd/server.c:116(sig_term)
   SIGTERM: killing children
[2013/09/21 20:01:30.214204,  0] ../source4/smbd/server.c:121(sig_term)
[2013/09/21 20:01:30.213612,  0] ../source4/smbd/server.c:121(sig_term)
   Exiting pid 30867 on SIGTERM
   Exiting pid 30870 on SIGTERM
[2013/09/21 20:01:30.343028,  0] 
   samba version 4.0.9-SerNet-RedHat-4.el6 started.
   Copyright Andrew Tridgell and the Samba Team 1992-2012
[2013/09/21 20:01:30.607037,  0] 
   samba: using 'standard' process model

...and log.smbd doesn't have anything from recent days.  smb.conf has 
this for its global section:

         workgroup = MYDOM
         realm = mydom.lan
         netbios name = NEWDC
         server role = active directory domain controller
         server services = rpc, nbt, wrepl, ldap, cldap, kdc, drepl, 
winbind, ntp_signd, kcc, dnsupdate, smb, dns
         allow dns updates = true
         dns forwarder =
         dcerpc endpoint servers = epmapper, wkssvc, rpcecho, samr, 
netlogon, lsarpc, spoolss, drsuapi, dssetup, unixinfo, browser, 
eventlog6, backupkey, dnsserver, winreg, srvsvc

My question is, if I down OLDDC, will NEWDC be able to successfully 
serve Group Policy to our WinXPSP3 clients, or does this error indicate 

If it won't work, what can I do to fix it?  I see a couple recent-ish 
threads about this but no answer to the one, and the other I've already 
seemed to incorporate the answer of into smb.conf.


More information about the samba mailing list