[Samba] creating an ubuntu package of version 4.1.0

bugblatterbeast samba at bugblatterbeast.de
Thu Oct 31 06:34:57 MDT 2013

Am 30.10.2013 02:09, schrieb Trent W. Buck:
> bugblatterbeast <samba at bugblatterbeast.de> writes:
>> It's compiling nicely now, but I still get this linker-error:
>> default/source3/lib/util_58.o: In function `str_checksum':
>> /home/nils/build2/samba4/bin/../source3/lib/util.c:1310: undefined
>> reference to `hash_any'
>> Did this happen to anybody before? Did anybody already succeed in
>> building a ubuntu- or debian-package of samba 4.1.0?
> FWIW Andrew Bartlett told me yesterday that the Debian Samba team are
> (understandably) currently focused on getting *any* samba4 into jessie;
> 4.1 isn't their priority right now.
> I had a quick look at the source and the missing symbol is internal to
> samba (ref. below); my gut feel is a missing dependency declaration
> somewhere in wscript such that the linker gets util where it should get
> both util and hash.
> I'd need your .dsc and .debian.tar.xz and build log to poke around more.
>      $ git checkout samba-4.1.0
>      $ grep -r hash_any *
>      lib/ccan/hash/hash.h:#define hash(p, num, base) hash_any((p), (num)*sizeof(*(p)), (base))
>      lib/ccan/hash/hash.h:uint32_t hash_any(const void *key, size_t length, uint32_t base);
>      lib/ccan/hash/hash.c:uint32_t hash_any(const void *key, size_t length, uint32_t base)
> Useful resources:
>    - #debian-mentors on irc.oftc.net (general Debian packaging advice & review)
>    - https://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-samba-maint
> #d-mentors will definitely be happy to help you packaging 4.1, even if
> it's only for personal use.  I'm not on pkg-maint-samba so I'm not sure
> how focused they are.
Hello Trend,

I've already send an answer with the requested files, but it's still 
waiting for a moderator's approval (because of the size). So I send the 
text-content once more without attachments.

thanks alot, that was very helpful. I've added the dependency ccan-hash 
to samba-util and now it's compiling and linking. Unfortunately the 
library-dependency-check still fails while checking libntdb.so.0.

dpkg-shlibdeps: error: no dependency information found for 
(used by debian/python-samba/usr/lib/x86_64-linux-gnu/samba/libdbwrap.so).

That (and some other hints) gave me the impression, it might not have 
been a good idea, to reactivate DISABLE_NTDB and so I've tried to find 
another way. Unfortunately: without DISABLE_NTDB, it wouldn't start 
compiling and keeps asking for ntdb >= 0.9 to be already installed. I 
don't understand waf very well and I haven't found out yet, what's 
causing that.

I'll attach the files you've asked for. The debian.tar.gz still contains 
the deactivated patches I've used to disable ntdb. I'd be happy if you 
have any idea, what the problem is, but you don't have to spend your 
time, poking around in my files (I guess that would take hours). You did 
me a huge favour already. I will definitely check out the resources you 

Thank you very much, nice regards, bbb

More information about the samba mailing list