[Samba] Folder redir : pb after moving user to subtree // solved

me at electronico.nc me at electronico.nc
Wed Oct 30 17:01:37 MDT 2013

Le 31/10/2013 09:49, me at electronico.nc a écrit :
> Hi all,
> Not sure if it's Samba or AD relative, but there are experts here :-)
> So :
> New Samba 4.1 AD DC compiled from git
> New Domain provision
> Created : ou=users
> Setup GPO for user's Documents and Desktop redirection to samba [home] 
> share, available offline, applied to ou=users
> Created users test1 and test2 in ou=users
> Loggued users test1 and test2 through Windows7
> ->
> Everything works like a charm (only allowed user can see his Desktop 
> and Documents, etc...)
> Created : sub ou=administrative in ou=users
> Moved user test2 to ou=administrative,ou=users
> -> test2 can't access his Documents or Desktop anymore after login
> Permissions on his home folder are still the same (seen from 
> Administrator account)
> Moved user test2 back to ou=users
> -> test2 still can't his Documents or Desktop anymore
> For sure if a new user test3 is created (and not moved) in 
> ou=administrative,ou=users : everything is normal.
> I'm "a bit" confused with what happens.
> Thanks in advance for your time and lights.
> Nicolas
... AD problem ...
‘Move contents to new location’ has to be DISABLED in the Folder Redir GPO !
Hope this will help some.
(this might worth to be mentionned in Samba Wiki about folder redir)

More information about the samba mailing list