[Samba] Samba 4.0.10 - 4.1.0 - master can no longer join existing Win2003 domain?

Mauricio Alvarez maurialvarez303 at rocketmail.com
Fri Oct 11 11:54:51 MDT 2013


   I can NO LONGER join the existing win 2003 domain (functional level win 2003, I also have installed Group Policy Client Side Extensions for Windows Server 2003).

I am running on Ubuntu Server 13.04. I have tried Samba 4.0.10, 4.1.0 and also, in desperation, samba-master.

I managed to join the domain with samba 4.0.8 (not sure if it was .8 or .9, it was in mid-September), downloaded via git, compiled and followed the wiki.

All was running OK for some time, until I found out it wan no longer replicating. Then I noticed WERR_VERSION_MISMATCH errors when running drs showrepl.

Since I was no longer able to demote the Samba4  DC, I decided to manualy delete from the Win2003, delete the samba4 directories and start over.

Now when I try join the domain it fails with 
ERROR(<type 'exceptions.AttributeError'>): uncaught exception - 'drsuapi.DsBindInfoFallBack' object has no attribute 'supported_extensions'

I tried google but I have no idea what this error means. All versions of Samba4 I tried give same error. I am sure I am doing exactly all the steps I did when I managed to join the domain the first time, and also on the Wiki.

I am probably missing something.

Can anybody please please please help or at least point me in the right direction? 


More information about the samba mailing list