[Samba] Point'n Print setup on Samba4 failing to install drivers

Marc Muehlfeld samba at marc-muehlfeld.de
Tue Oct 8 14:01:57 MDT 2013

Am 08.10.2013 18:53, schrieb Pablo T. Virgo:
>> - Can you show the output of "getfacl" on the directory?
>> - What filesystems is this share on?
>> - Is it mounted with user_xattr?
> Details on the share:  /var/samba/print_drivers is on the /var partition, which is mounted with user_xattr, as per the Domain Setup howto.
> Here is the current output on the share.  I've tried it with the local owner as root:root as well.
> getfacl /var/samba/print_drivers/
> getfacl: Removing leading '/' from absolute path names
> # file: var/samba/print_drivers/
> # owner: 3000000
> # group: users
> user::rwx
> user:root:r-x
> group::r-x
> group:root:r-x
> group:users:r-x
> group:3000000:rwx
> group:3000008:rwx
> mask::rwx
> other::r-x
> default:user::rwx
> default:user:root:rwx
> default:user:3000000:rwx
> default:group::r-x
> default:group:root:r-x
> default:group:users:r-x
> default:group:3000000:rwx
> default:group:3000008:rwx
> default:mask::rwx
> default:other::r-x
>> I wrote that HowTo in June. So I think I had tested everything with
>> 4.0.6. What version are you running?
>> What OS/Distribution/Version are you running?
> I compiled Samba 4.0.9 on Debian Wheezy (stable).

>> If I have time later, I can try setup printing on my test environment to
>> re-validate the HowTo.

I setup a print server based on my HowTo with 4.0.10. As permissions for 
the driver share folder I simply just set 755 (no permissions set on 
windows on the share nor on the filesystem).

Printer driver upload works fine (I tried the Win7 driver of a Sharp 
MX-2600n PS).

But I found a bug if only x64 drivers are uploaded:
I'll add a hint to the HowTo about that.


More information about the samba mailing list