[Samba] vestigial DNS entries

Lee Allen lee at leecallen.com
Tue Nov 26 13:34:22 MST 2013

I am running samba 4.2.0 as an AD with internal DNS.

I had an earlier version of Samba4 that was running old code and the system
had gotten cluttered up from my learning process.  I chose to replace it by
bringing up a new Samba4 DC, letting them sync, then promote the new, and
demote the old.  That all worked flawlessly.  Eventually I destroyed the
old Samba4 system.

Today I tried to play around with SWAT and I see my samba log is full of
failed attempts to connect to -- that was my old Samba4 AD,
now destroyed.  The only place I can find any reference to that IP address
is when I do "samba-tool dns query ... @", it shows:

  Name=, Records=2, Children=0
    A: (flags=600000f0, serial=1, ttl=900)
    A: (flags=600000f0, serial=110, ttl=900)

That is, a null name, and the IP addresses of my old/defunct AD (.13) and
my current/operational AD (.5).

How can I get rid of the 0.13 record?  Are both of these records incorrect?



More information about the samba mailing list