[Samba] Sysvol replication

Jim Potter jimpotter at orange.net
Wed May 29 15:24:20 MDT 2013

Hi Robert,

The sysvol share (or possibly AD userand and computers) is really 
pedantic about attributes. I've got it all working so that it looks fine 
(replication works by whatever means) but ADUC kicks up errors. For 
rsync I get permission errors (different uidnumbers for specific users 
and groups on different servers), but with gluster is says it can't set 
the permissions and dies. I haven't tried DRBD...

What you are proposing looks more like 1 active DC with a failover 
solution rather than having multiple DCs running simultaneously, right? 
I hadn't really looked at that... I was just following the MS approach 
of 'you need multiple DCs if you are doing anything serious' model. That 
would be wortha look in some scenarios, but where I am I've got ~850 
workstations in a school (so all log in within 5 minutes of each other 
at the start of each lesson) so the ability to add DCs until they can 
handle the load is pretty essential.



On 29/05/2013 21:45, Sandbox wrote:
> Hi
> I thinking about HA+DRBD, you can mount the partition with acl, 
> user_xattr settings, I using this method for shares, this should work 
> with the sysvol directory too?!
> Btw,is it possible to store the PDC's *.tdb files on that kind of 
> partition and when the PDC dies the BDC's HA mounts the 
> shares/tdb/sysvol partitions and loads the correct smb.conf.
> For me it make sense, since all data is available only for the active 
> server. Of course you have to back up the tdb files with tdbbackup.
> Regards, Robert
> 2013-05-29 09:30 keltezéssel, Jim Potter írta:
>> Hi,
>> Sorry about late reply...
>> I've been baning my head againstr replication here for a while...
>> GlusterFS - it seems to have problems with the extended attributes 
>> specifically on the point where the gluster FS is mounted.
>> For example: I have a standard debian setup with sysvol in 
>> /var/lib/samba/ and mount a gluster sysvol partition here (with 
>> xattrs) I can set attributes within the partition fine, but I can't 
>> set the attributes on the sysvol folder itself, or they won't inherit 
>> properly...
>> I also came unstuck on uidnumbers across DCs (see previous email), 
>> but I was just getting an error from GPMC saying permissions were all 
>> wrong (paraphrased!)
>> My next approach (not tested yet) is to get the mount point out of 
>> the share, eg:
>> - mount gluster FS in /srv/glusterMounts/sysvol and in here have a 
>> directory sysvol which I share as my sysvol share:
>> [sysvol]
>> path = /srv/glusterMounts/sysvol/sysvol
>> How do you do it to get it to work?
>> cheers
>> Jim
>> On 15/04/2013 08:25, Daniel Müller wrote:
>>> For my interest!? What are your issues about gluster not working 
>>> replicating
>>> sysvol?
>>> Greetings
>>>   Daniel
>>> -----------------------------------------------
>>> EDV Daniel Müller
>>> Leitung EDV
>>> Tropenklinik Paul-Lechler-Krankenhaus
>>> Paul-Lechler-Str. 24
>>> 72076 Tübingen
>>> Tel.: 07071/206-463, Fax: 07071/206-499
>>> eMail: mueller at tropenklinik.de
>>> Internet: www.tropenklinik.de
>>> -----------------------------------------------
>>> -----Ursprüngliche Nachricht-----
>>> Von: samba-bounces at lists.samba.org 
>>> [mailto:samba-bounces at lists.samba.org] Im
>>> Auftrag von Jim Potter
>>> Gesendet: Sonntag, 14. April 2013 22:34
>>> An: samba
>>> Betreff: [Samba] Sysvol replication
>>> Hi all,
>>> Has anyone actually got sysvol replication working between 2 (or more)
>>> Samba4 DCs? I've tried gluster, inosync, csync and rsync and keep 
>>> getting
>>> stuck on issues with the extended attributes.
>>> Is there a roadmap or any clues of a date when MSFRS or DFS 
>>> replication will
>>> be part of Samb4?
>>> thanks again,
>>> Jim
>>> -- 
>>> To unsubscribe from this list go to the following URL and read the
>>> instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list