[Samba] Procedure for installing Windows drivers on Samba with CUPS

Tim Vangehugten timvangehugten at gmail.com
Thu May 23 02:19:32 MDT 2013

@steve yes I am sure as I am able to print now in my test-network :)

These are the steps I have done on a freshly installed ubuntu 12.04 server:

1: Downloaded and extracted samba-4.0.6.tar.gz
2: Patched dns_crypto.c in /source4/dns_server/
with 0001-Fix-internal-DNS-dyn.-update-seen-as-TSIG-error-with.patch
3: Did provision with samba internal dns backend and downloaded an
4: Did a "krb5_newrealm SAMBA.MY.DOMAIN"
5: mkdir /var/spool/samba and /usr/local/samba/var/print
6: chmod 1777 /var/spool/samba and /usr/local/samba/var/print
7: added the following to my smb.conf in /usr/local/samba/etc/smb.conf:

printcap name = cups
printing = cups

        comment = Printer Drivers
        path = /usr/local/samba/var/print
        read only = no

        comment = All Printers
        browseable = yes
        printable = yes
        read only = no
        path = /var/spool/samba

8: installed and configured cups
9: started samba
10: added the windows drivers to the samba share like Adam Nielsen said
11: I could print

That's about it for printing, the patch I did was for my samba4-failover
server if you don't patch it it errors on dns updates...
Hope this helps.

Best regards
Tim Vangehugten

2013/5/23 steve <steve at steve-ss.com>

> On Wed, 2013-05-22 at 21:15 -0500, Ricky Nance wrote:
> > Those instructions should still work for XP, but its quite a bit
> > different for windows 7, I need to do a wiki page on it, and will when
> > I get some spare time, but not sure when that will be.
> Thanks Ricky
> I just tried it with a xp client. The same error: Access is denied. Is
> there anything trivial missing from those wiki notes which prevent
> printing working with 4.0.6?
> Steve
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list