[Samba] Samba4 on hosted root server

Carsten Laun-De Lellis carsten.delellis at delellis.net
Wed May 8 01:54:54 MDT 2013

Hi list 

I am trying to install Samba4 on a hosted server but haven't been
successful yet. 


Hosted Server with official .net domain. OS is Ubuntu 12.04 LTS Server
64-bit. DNS for domain is registred with provider's name servers. 

Installed Samba with Bind backend following the how-to on
[1] . 

When I tried to join the domain I got an error message that SRV
_ldap._tcp.dc.msdcs.official.domain not found. No DC can't be located. 

I checked if name service is working properly on the server itself: 

> host -t SRV _ldap._tcp.dc.msdcs.official.domain 

_ldap._tcp.dc.msdcs.official.domain has SRV record 0 0 389

>host -t SRV _kerberos._udp.official.domain 

_kerberos._udp.official.domain has SRV record 0 0 88

>host -t SRV _ldap._tcp.official.domain 

_ldap._tcp.official.domain has SRV record 0 100 389

Everything looks fine 

I tried the same from another linux server with: 

>host -t SRV _ldap._tcp.dc.msdcs.official.domain [server-ip] 

Also everything works fine. I've got the same replys. 

But whenever I try to join the domain it doesn't work. 

I would appreciate any help and ideas. 


Carsten Laun-De Lellis

Hauptstrasse 13
D-67705 Trippstadt

Phone: +49 6306 992140
Fax: +49 6306 992142
Mobile: +49 151 27530865
email: carsten.delellis at delellis.net

http://www.linkedin.com/in/carstenlaundelellis [2] 

[2] http://www.linkedin.com/in/carstenlaundelellis

More information about the samba mailing list