[Samba] pdbedit error

Robert Steinmetz AIA rob at steinmetznet.com
Thu Jun 20 15:57:21 MDT 2013

Samba Version 3.6.3 on Ubuntu 12.04 tbdsam back end.

I discovered a couple of accounts we created before the Domain was 
configured was was an account named "administrator" intended to be the 
Smaba Administrator account. In order to change the domain ai ran this 

# pdbedit -I "DOMAINNAME" -U username

it worked on a number of accounts when I tried it on administrator I get the

# pdbedit -I "DOMAINNAME" -u administrator
Unable to modify TDB passwd: NT_STATUS_UNSUCCESSFUL!
Unable to modify entry!

# pdbedit -v -u administrator gives the following output

Unix username:        administrator
NT username:
Account Flags:        [U          ]
User SID:             S-1-5-21-1504512832-3249319461-1142831928-500
Primary Group SID:    S-1-5-21-1504512832-3249319461-1142831928-513
Full Name:            Samba Administrator,,,
Home Directory:       \\hamlet\administrator
HomeDir Drive:        U
Logon Script:
Profile Path:        deleted for privacy
Domain:               HAMLET
Account desc:
Munged dial:
Logon time:           0
Logoff time:          never
Kickoff time:         never
Password last set:    Fri, 30 Dec 2005 17:29:27 CST
Password can change:  Fri, 30 Dec 2005 17:29:27 CST
Password must change: never
Last bad password   : 0
Bad password count  : 0

I don't see anything here that looks out of place but I don't know what 
it all means.

rob steinmetz

More information about the samba mailing list