[Samba] dynamic DNS Updates still failing, re-installed 9 more times, tried everything I could think of, now bald.

Gary Maurizi garymaurizi at gmail.com
Mon Jun 3 04:07:53 MDT 2013

Thank You Thank You Thank You!!!!!!!!!!!!!!!!!!


CentOS base AND epel bind9.8 packages both compile with this, this IS/WAS
the cause of my and every other samba4 CentOS 6 users issue with dynamic
DNS updates.

01. Downloading the source RPM, removing this line from the build

02. and changing --with-gssapi=yes TO: '--with-gssapi=/usr/include/gssapi

03. and adding the line --with-dlopen=yes

04. and re-installing bind, and then proceeding with the samba 4 domain
controller tutorial fixed the issue.

I apologize for being the squeaky wheel here, but this is the first time in
15 years I have run into a problem I could not find a solution to with all
of the google-fu in the world. I even tried recompiling the official bind
9.9.?3 tarball from ISC source with the two options in the build tutorial
and ran into the same issues, as --disable-isc-spnego was built in that way
as well.

Thank You for updating the WIKI, maybe even a note that the CentOS 6
version of bind available via YUM will not work, or a note to check with
named -V that --disable-isc-spnego is not in your build, and that
--with-gssapi=yes is wrong and needs to read
--with-gssapi=/usr/include/gssapi or something of that sort, as when I was
working through this, the build-bind page contained only "GSSAPI and dlopen
support" mentions.

A.Bartlett you have been a tremendous help, and I have learned a ton
trouble shooting this issue, not least of all where the advil was hiding in
the medicine cabinet.

I hope to pass it on.


On Mon, Jun 3, 2013 at 12:57 AM, Andrew Bartlett <abartlet at samba.org> wrote:

> On Mon, 2013-06-03 at 08:02 +0200, steve wrote:
> > On Mon, 2013-06-03 at 09:36 +1000, Andrew Bartlett wrote:
> > > On Mon, 2013-06-03 at 01:11 +0200, steve wrote:
> > > > On Mon, 2013-06-03 at 08:16 +1000, Andrew Bartlett wrote:
> >
> > > >
> > > > End users need something simple to install. We also need something
> that
> > > > does dynamic dns reliably. The strong points of the internal dns are
> > > > it's simplicity of installation. Would it be possible to get it to do
> > > > dns updates from nsupdate?
> > >
> > > It does do dns updates from nsupdate.  There is a client-side error
> > > shown *after* the successful update, but the developer who developed
> the
> > > patch for this hasn't been able to write the tests to allow his changes
> > > to make it into master.
> >
> > Hi
> > No, I'm sorry but it doesn't. The record goes in once and that's that.
> > You then can't change it. Not with nsupdate. Not with samba-too dns. The
> > only way to free it is to samba_upgradedns to BIND9_DLZ it.
> Please re-test with current master and if it still an issue please file
> a bug.
> Andrew Bartlett
> --
> Andrew Bartlett                                http://samba.org/~abartlet/
> Authentication Developer, Samba Team           http://samba.org
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list