[Samba] samba runs only in interactive mode

Gints Neimanis gintsn at gmail.com
Wed Jul 31 10:06:11 MDT 2013


We have migrated our old Win2000 AD domain (~ 1000 user accounts) to 
Samba 4.0.7 AD, but some things doesn't work as expected (samba process  
crashes a few times a day/week with   PANIC without any noticeable 
reason; samba dbcheck can't fix some db errrors and so on) , and I'm 
trying to resolve the issues. I tested this on various servers (Debian 
wheezy, Ubuntu 12.04) and different samba versions (4.0.6, 4.0.7, 
4.1.rc1) - the issues remain the same.

Now the problem - I can run samba only in interactive mode
When I run in tmux session with command
/usr/local/samba/sbin/samba -i  -d 3 -M single
then samba accepts incoming connections/authorization and so on, until 
it crashes after some hours or days
For example, I can access netlogon share:

smbclient //vasec/netlogon -k -c exit
Domain=[SKOLA] OS=[Unix] Server=[Samba 4.1.0rc1]

When I run samba in daemon mode, then it stops responding (but still 
shows in process list)
/usr/local/samba/sbin/samba  -d 3 -M single

smbclient //vasec/netlogon -k -c exit
session setup failed: NT_STATUS_IO_TIMEOUT

server log file shows nothing valuable (at least for mee):

Any ideas how to fix or troubleshoot it?

More information about the samba mailing list