[Samba] SMB4 ADDC possible attribute corruption

Simon Thorley simon at thenom.co.uk
Thu Jul 25 09:45:52 MDT 2013

Hi All,

I am having a problem with SMB4 ADDC.  I cannot join the AD from Fedora.
I have done a wireshark capture and found that it does 2 LDAP search
requests when doing a discovery.

The 1st query was a search for the defaultNamingContext and
supportedCapabilities attributes.  This got a successful search response
packet and a result of 1.
the 2nd query was a search for the NetLogon attribute.  This also got a
successful search response packet but it had a result of 0 so no attribute

I am currently using RealmD to join and get: ! Received invalid or
unsupported Netlogon data from server
I get this from both discover and join

samba 4.0.7
compiled from source

Realmd discover normally lists required packages to join a certain domain
but as it wasn't working a tried installing any packages that i thought it
would require.
krb5-workstation is installed but not configured as realmd should do this.
I have tried this on 2 F19 fresh installs and both have the same fault.
i also did a packet capture whilst discovering another 2008R2 domain and
the netlogon attribute on the LDAP search was fully populated.  This was an
MS Win2008 DC though.

I am not sure if this LDAP result is the failure of the join but the packet
capture finish very abrubtly after that with a couple of ACK's and FIN's.

What might throw a bit of a spanner in the works is that i joined the AD
fine from a Win7 VM.  Not sure if Win7 is unreliant of this netlogon
attribute to join.

Thanks in advance.

More information about the samba mailing list