[Samba] Winbind troubles

Rowland Penny rowlandpenny at googlemail.com
Mon Jul 22 13:41:09 MDT 2013

Have you tried 'getent passwd username'


On 22 July 2013 19:56, Matthew Daubenspeck <matt at oddprocess.org> wrote:

> I've rolled 2 virtual servers running Ubuntu 12.04 LTS and have
> installed the SerNet packages. SRV1 has the AD setup and SRV2 is a
> member server. I've followed the wiki for both servers to the letter,
> and winbind still refuses to grab info on the member server.
> I rolled the provision with --use-rfc2307, added a bunch of users with
> samba-tool. I then manually created a group and made sure it had valid
> gid. I then did the same with the 3 users, made sure their primary group
> was set, and they had valid UIDs. All 3 users have UIDs of 10000, 10001,
> and 10002. The single group has a GID of 10000 and all 3 users are a
> member.
> I joined the domain fine, everything appears correct in DNS, and the
> SRV2 member server shows up in ADUC under Computers. Both smb.conf files
> match exactly (except for the domain names) the config file
> examples in the wiki articles.
> wbinfo -u and wbinfo -g both work and pull the proper users/groups.
> However, when I run getent passwd all I get is local users.
> I checked and re-checked libnss_winbind.so with ldconfig -v, and that is
> there as well. What the heck could I be missing? I've followed
> everything to the letter.
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list