[Samba] domain provision error

Gregory Sloop gregs at sloop.net
Sun Jan 27 15:00:57 MST 2013

[I sent this back on Friday AM, but it claimed it was being held, yet
I've not seen it show up, so I'm reposting both to update the thread,
as well as for others who might be having the same issue. My apologies
if it eventually shows up twice.]

As was posted initially, I got a whole set of errors in doing my
domain provisioning. The error messages looked like they pointed
toward not having ACL support in the filesystem, or in Samba, or not
having the ACL packages installed.

[See the bottom of the message for a partial repost of the error.]

So, in frustration I nuked the test-bed setup and completely
reinstalled the OS, pulled Samba and all packages, re-compiled etc.

And I made the same mistake as the first time - I used a password that
didn't meet the complexity requirements and the provision script
bombed. But I just thought I'd re-run it with a "better" password. And
*boom* the same error as below - a second time.

That started me thinking that the issue was probably that the
provision script didn't know how to handle things if it was only half

So, I tried deleting the smb.conf file and trying again. [As suggested
in the Wiki.] But that didn't do it either.

So, I nuked it from orbit - the only way to be sure!
rm /usr/local/samba/ -rf
[I installed to the default - but if you're having the same issue,
make sure you delete the path you installed to, as long as nothing
else is valuable there... :) ]

The I did a samba {make install] again to put the files back.

Re-ran the [domain provision] again, making sure to use a complex
enough password and the provision completed without error.

I might suggest that someone who knows that script include some error
handling that would at least kick meaningful error messages in the
same situation. [It doesn't have to roll things back "automagically"
but if it would at least recognize what was the problem and provide
feedback that would clue one in about what was *really* wrong and
perhaps what to do to fix it.]

Hope that helps someone else - or prompts a re-write of the script.

Thanks for all the help attempts!


Error output from original posting below. [To help your google-fu!]
> When doing the domain provisioning I get these errors.
> ---
> Asks for Relm/Domain/DNS/Samba type [ad] etc...
> Then...
> ...
> ldb: module schema_load initialization failed : No such object
> ldb: module rootdse initialization failed : No such object
> ldb: module samba_dsdb initialization failed : No such object
> ldb: Unable to load modules for /usr/local/samba/private/sam.ldb: (null)
> samdb_connect failed
> VFS connect failed!
> ERROR(<class 'samba.provision.ProvisioningError'>): Provision failed -
> ProvisioningError: Your filesystem or build does not support posix ACLs,
> which s3fs requires.  Try the mounting the filesystem with the 'acl'
> option. File
> "/usr/local/samba/lib/python2.7/site-packages/samba/netcmd/domain.py",
> line 398, in run use_rfc2307=use_rfc2307, skip_sysvolacl=False)
>   File
> "/usr/local/samba/lib/python2.7/site-packages/samba/provision/__init__.py"
> , line 1965, in provision raise ProvisioningError("Your filesystem or build
> does not support posix ACLs, which s3fs requires.  Try the mounting the
> filesystem with the 'acl' option.") ---
> Yet, I find:
> /usr/local/samba/lib/ldb/schema_load.so
> /usr/local/samba/lib/ldb/samba_dsdb.so
> /usr/local/samba/lib/ldb/rootdse.so
> 1)These all exist.
> 2) Running as root, and files are [r x] for root.
> Also, a mount shows this for the / partition: (rw,acl,errors=remount-ro)
> So, it appears that I have ACL support too.

More information about the samba mailing list