[Samba] Samba4 Classicupgrade Failed

Mario Codeniera mario.codeniera at gmail.com
Wed Jan 23 21:51:13 MST 2013


I used to solved this problem, hope that it will helps for others who will
encountered the same issue which took me days to figure it out. As you can
see the logs it is using python 2.4 (see for example File
line 142, in _run) even I told before that I used to upgrade to Python2.7
but "samba-tools domain classicupgrade" seems to see the Python2.4.

Here are the steps:
1) Install the needed packages for the Python2.7 first
*yum groupinstall "Development tools"*
*yum install zlib-devel*
*yum install bzip2-devel*
*yum install openssl-devel*
*yum install ncurses-devel*
*yum install readline-devel*

2) Download the Python source code. (You can use also latest version 3.xx)
*wget http://www.python.org/ftp/python/2.7.3/Python-2.7.3.tar.bz2*
*tar xvf Python-2.7.3.tar.bz2*
*./configure --prefix=/usr/local --with-threads --enable-shared*
*make && make install*
*         T*ake note: you can use *make altinstall *(if you want two python
(a big and small, lol), meaning Python2.4 and Python2.7

*ln -s /usr/local/lib/libpython2.7.so.1.0 /usr/lib*
         If you can't find it, please do search.

3) Check the python if the version is correct.

       Python 2.7.3 (default, Jan  23 2013, 16:43:58)
       [GCC 4.1.2 20080704 (Red Hat 4.1.2-46)] on linux2
       Type "help", "copyright", "credits" or "license" for more

4) Optional (running before testing using step#3)
*tar xvf distribute-0.6.27.tar.gz*
*cd  distribute-0.6.27*
*python2.7 setup.py install*
*easy_install-2.7 virtualenv*

5) Finally check using yum
*yum search elinks*
Then refer to the howto in samba for details
*git clean -x -f -d*
*rm -rf /usr/local/samba*
recompile it back see

Viola! you will not able to see these logs anymore, but another steps of
problems soon you will encounter which is another story.


On Tue, Dec 4, 2012 at 3:21 PM, Mario Codeniera
<mario.codeniera at gmail.com>wrote:

> Hi,
> I am stuck on upgrading the current Samba3 to Samba4, currently used Samba
> 3.3.10 and upgraded to Samba 3.4.17 still the same problems below. I also
> try to upgrade the Python 2.4.3 to Python 2.7 still same problems, with the
> OpenLDAP 2.3.43.
> [root at ewanko]# /usr/local/samba/bin/samba-tool domain classicupgrade
> --dbdir=/var/lib/samba/  --use-xattrs=yes  --realm=ewanko.local
> /etc/samba/smb.conf
> ERROR(exceptions.TypeError): uncaught exception - __init__() got an
> unexpected keyword argument 'epilog'
>   File "/usr/local/samba/bin/samba-tool", line 44, in ?
>     retval = cmd._run("samba-tool", subcommand, *args)
>   File
> "/usr/local/samba/lib/python2.4/site-packages/samba/netcmd/__init__.py",
> line 201, in _run
>     return self.subcommands[subcommand]._run(
>   File
> "/usr/local/samba/lib/python2.4/site-packages/samba/netcmd/__init__.py",
> line 201, in _run
>     return self.subcommands[subcommand]._run(
>   File
> "/usr/local/samba/lib/python2.4/site-packages/samba/netcmd/__init__.py",
> line 142, in _run
>     parser, optiongroups = self._create_parser(argv[0])
>   File
> "/usr/local/samba/lib/python2.4/site-packages/samba/netcmd/__init__.py",
> line 130, in _create_parser
>     prog=prog,epilog=epilog)
> Are there any links for those successfully upgrade their samba 3 to samba
> 4?
> Regards,
> Mario

More information about the samba mailing list