[Samba] 回复: configure with --with-ads failed get "krb5 libs don't have allfeatures required for Active Directory support" error

Andrew Bartlett abartlet at samba.org
Wed Feb 27 14:54:48 MST 2013

On Wed, 2013-02-27 at 21:15 +0800, 枫叶 wrote:
> thanks very much for answer.
> I  think if I just want to build file server of samba4, it should use
> the autoconf source3/ build system to build samba, is it right?

No, you should use the top level build.  It builds smaller binaries, due
to the use of shared libraries.  You can build --without-ad-dc.

> do you mean if I want to use a system MIT kerberos, it require
> kerberos1.8 or above in
> source3?  I found it can build samba-3.6.9/source3 wit MIT
> kerberos1.4. is it right? 

With Samba 4.0, we increased the minimum MIT kerberos version that we
require, if you want to build against the system MIT kerberos version.

In the top level (waf) build, the configure flag --with-system-mitkrb5
must be specified to build against a system MIT kerberos.

Andrew Bartlett

Andrew Bartlett                                http://samba.org/~abartlet/
Authentication Developer, Samba Team           http://samba.org

More information about the samba mailing list