[Samba] some DNS trouble ...

moss.mose at gmail.com moss.mose at gmail.com
Tue Feb 26 01:33:32 MST 2013

Hi list !

I ran into some interesting behavior I don't understand.
I'm using samba4 as my domain controller in a virtual machine.
My settings are as follow:

	server role = domain controller
	workgroup = LAN
	realm = lan.example.com
	netbios name = ADC
	passdb backend = samba4
	dns recursive queries = yes
	dns forwarders =

	path = /var/lib/samba/sysvol/lan.vbk.at/scripts
	read only = No

	path = /var/lib/samba/sysvol
	read only = No

the IP of the ADC is

it seems that the DNS forwarding does not work, because if I only use the IP of my ADC in my clients they can resolve the internal names but nothing from outside (internet)
When I set the ADC as my primary and my router's IP ( as the secondary DNS server within my clients everything works like a charm …
So far so good … theoretically I could live with such a setting, even though not what I intended in the first place, but the real trouble started when I connected via VPN and tried to get outside.
Here setting primary and secondary DNS does not work like it did before.
Setting only my ADC results in being able to resolve internal names but no outside.
Setting the router as my secondary results in being able to resolve outside but no inside.
I'm using a TL-ER6020 as my vpn-/router and ubuntu 12.04LTS within a XEN virtualization environment.

Any hints and comments are highly appreciated :)

More information about the samba mailing list