[Samba] Upgrade from 4.0.0 to 4.0.3 creates unfixable errors with dbcheck

Chris Lewis clewis at inview.co.uk
Sun Feb 24 04:28:12 MST 2013

Hi Nico

Tried with make clean and with a fresh build from the 4.0.3 source. Yielded same issue.



Nico Kadel-Garcia <nkadel at gmail.com> wrote:

On Thu, Feb 21, 2013 at 8:11 AM, Chris Lewis <clewis at inview.co.uk> wrote:
> Hello,
> Today I tried to upgrade from samba 4.0.0 to 4.0.3 on my test environment.
> I patched the source with the diffs patch-4.0.0-4.0.1.diffs,
> patch-4.0.1-4.0.2.diffs, patch-4.0.2-4.0.3.diffs , then make, make install.

I don't see a "make clean" in there, and it doesn't seem to be
available anymore with the new Python based build system.

Rather than compiling on top of your old code, which may not
completely detect dependencies on altered include files and force
rebuilding of new binaries, why don't you work from a fresh source
tree and build from scratch? This is especially important when the
build components themselves, such as that Python "waf" build tools,
may be modified by the udpates.

More information about the samba mailing list